Страница 1 из 2 12 ПоследняяПоследняя
Показано с 1 по 10 из 13

Тема: Некорректно работает макрос %Attachments

  1. #1
    Новичок
    Регистрация
    15.09.2004
    Сообщений
    8

    Некорректно работает макрос %Attachments


    При создании нового письма по шаблону, содержащему макрос %Attachments, если первым делом прикрепить файлы, то макрос работает без проблем, но если вначале написать хотя бы одно слово в теле письма, а затем прикрепить файлы, то макрос так и останется <none>.

  2. #2
    Участник Аватар для Vadim
    Регистрация
    01.11.2002
    Сообщений
    4,711

    Re:Некорректно работает макрос %Attachments

    Это не некорректная работа, а ..... не буду говорить что...
    А ум включить слабо?
    %IF для проверки и все будет чики чики...

  3. #3
    Новичок
    Регистрация
    15.09.2004
    Сообщений
    8

    Re:Некорректно работает макрос %Attachments

    Буду очень признателен, если Ваши ответы будут содержать больше смыссловой нагрузки и уважения к спрашиваюшему. Я ведь за помощью обратился...
    Что такое %IF? Как его включать? Почему при пустом теле письма все в порядке, а призаполненном - не работает?
    Заранее спавсибо за ответ.

  4. #4
    Новичок
    Регистрация
    15.09.2004
    Сообщений
    8

    Re:Некорректно работает макрос %Attachments

    Прошу прощения за лирическое отступление - просто не удержался...
    Если не знаете как помочь - или так и скажите, или сразу пошлите меня на... А то создается впечатление, что когда нечего сказать - начинаются наезды. Я вроде не давал повода для этого.
    Извините, если был слишком резок.

  5. #5
    XYZ
    XYZ вне форума
    Участник Аватар для XYZ
    Регистрация
    23.10.2003
    Сообщений
    572

    Re:Некорректно работает макрос %Attachments

    Я чесно говоря тоже не понял, что имел в виду Vadim...

  6. #6
    GVD
    GVD вне форума
    Участник Аватар для GVD
    Регистрация
    05.11.2002
    Сообщений
    269

    Re:Некорректно работает макрос %Attachments

    Цитата Сообщение от alexpann
    Если не знаете как помочь - или так и скажите, или сразу пошлите меня на...
    Знаем... Иди... ;D Макросы шаблона отрабатываются однократно в момент подадания курсора в окно ввода... Т.е. в данном случае надо рыть в сторону "Быстрых шаблонов"
    А то создается впечатление, что когда нечего сказать - начинаются наезды.
    Напрасно ;D
    Извините, если был слишком резок.
    :P

  7. #7
    GVD
    GVD вне форума
    Участник Аватар для GVD
    Регистрация
    05.11.2002
    Сообщений
    269

    Re:Некорректно работает макрос %Attachments

    Цитата Сообщение от XYZ
    Я чесно говоря тоже не понял, что имел в виду Vadim...
    не понял - промолчи >

  8. #8
    Новичок
    Регистрация
    15.09.2004
    Сообщений
    8

    Re:Некорректно работает макрос %Attachments

    А вы не могли бы сбросить пример такого быстрого шаблона? Я не программер, врач по образованию. Просто Bat нравится.

  9. #9
    GVD
    GVD вне форума
    Участник Аватар для GVD
    Регистрация
    05.11.2002
    Сообщений
    269

    Re:Некорректно работает макрос %Attachments

    Цитата Сообщение от alexpann
    А вы не могли бы сбросить пример такого быстрого шаблона? Я не программер, врач по образованию. Просто Bat нравится.
    Вот обновлю фотографию - посмотрим похож ли я на программиста.

    Доступ к быстрым шаблонам в меню сам найдешь. А шаблон... Например такой
    к письму добавлены файл(ы): %ATTACHMENTS

  10. #10
    Новичок
    Регистрация
    15.09.2004
    Сообщений
    8

    Re:Некорректно работает макрос %Attachments

    Дык ребята... Создал быстрый шаблон, назвал Attach, в тексте шаблона: %Attachments; затем команду %QINCLUDE="Attach" забил в шаблон письма - и все также: при пустом теле работает, при заполненном - нет...
    Помогите, если что не так понял... ???

Похожие темы

  1. Некорректно отоброжаются HTML письма! Версия 3.62.12
    от I-Salt в разделе The Bat!: вопросы и ответы
    Ответов: 6
    Последнее сообщение: 12.11.2005, 00:21
  2. Макрос %ATTACHMENTS
    от Giorgievich в разделе The Bat!: вопросы и ответы
    Ответов: 1
    Последнее сообщение: 05.03.2004, 14:47
  3. Не работает галочка "Do not sent attachments" в режиме "Redirect the message to"
    от LordMAD в разделе The Bat!: вопросы и ответы
    Ответов: 0
    Последнее сообщение: 11.02.2004, 16:23
  4. Пропадают attachments
    от RE11 в разделе Архив первого форума
    Ответов: 3
    Последнее сообщение: 21.10.2002, 19:24

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •